Bug #101150 Crash when executing query
Submitted: 13 Oct 2020 11:21 Modified: 15 Oct 2020 13:16
Reporter: Edward Leigh Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.21 OS:Microsoft Windows (Microsoft Windows 10 Home)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[13 Oct 2020 11:21] Edward Leigh
Description:
MySQL Workbench eventually crashes when executing a query (often one that has been executed successfully before), typically after being open for several days. Here follows the end of of a sample log file:

>>>

11:50:15 [ERR][ sqlide-history]: Can't parse <ENTRY timestamp='00:14:22'>select nid, asset_name, work_title, work_title_clean, work_title_en&#x0A;FROM paris WHERE work_title_en = '' AND work_title REGEXP '[[::digit:]], [Nn][&deg;&ordm;]' AND dashIdx=0 ORDER BY RAND() LIMIT 1000</ENTRY>, of file: C:\Users\Edward\AppData\Roaming\MySQL\Workbench\sql_history\2016-05-03
11:50:15 [ERR][  XML Functions]: LibXml: Entity: line 1: 
11:50:15 [ERR][  XML Functions]: LibXml: parser 
11:50:15 [ERR][  XML Functions]: LibXml: error : 
11:50:15 [ERR][  XML Functions]: LibXml: Entity 'deg' not defined

11:50:15 [ERR][  XML Functions]: LibXml: OM paris WHERE work_title_en = '' AND work_title REGEXP '[[:digit:]], [Nn][&deg;

11:50:15 [ERR][  XML Functions]: LibXml:                                                                                ^

11:50:15 [ERR][  XML Functions]: LibXml: Entity: line 1: 
11:50:15 [ERR][  XML Functions]: LibXml: parser 
11:50:15 [ERR][  XML Functions]: LibXml: error : 
11:50:15 [ERR][  XML Functions]: LibXml: Entity 'ordm' not defined

11:50:15 [ERR][  XML Functions]: LibXml: is WHERE work_title_en = '' AND work_title REGEXP '[[:digit:]], [Nn][&deg;&ordm;

11:50:15 [ERR][  XML Functions]: LibXml:                                                                                ^

11:50:15 [ERR][ sqlide-history]: Can't parse <ENTRY timestamp='00:14:26'>select nid, asset_name, work_title, work_title_clean, work_title_en&#x0A;FROM paris WHERE work_title_en = '' AND work_title REGEXP '[[:digit:]], [Nn][&deg;&ordm;]' AND dashIdx=0 ORDER BY RAND() LIMIT 1000</ENTRY>, of file: C:\Users\Edward\AppData\Roaming\MySQL\Workbench\sql_history\2016-05-03
11:50:15 [ERR][SQL Editor Form]: Error querying performance_schema.events_statements_current
: Exception: SELECT command denied to user 'xxx'@'nn.nn.nn.nn' for table 'events_statements_current'
11:50:15 [ERR][SQL Editor Form]: Error querying performance_schema.event_stages_history
: Exception: SELECT command denied to user 'xxx'@'nn.nn.nn.nn' for table 'events_stages_history_long'
11:50:16 [ERR][SQL Editor Form]: Error querying performance_schema.event_waits_history
: Exception: SELECT command denied to user 'xxx'@'nn.nn.nn.nn' for table 'events_waits_history_long'

<<<

It may be that the db connection has timed out and MySQL Workbench has not, on this occasion, reopened it.

A possibly related bug is that MySQL WB is using the wrong SQL history file - in this case 2016-05-03.

How to repeat:
Use MySQL Workbench for an extended period of time?
[15 Oct 2020 13:16] MySQL Verification Team
Hello Edward Leigh,

Thank you for the bug report.
This is most likely duplicate of Bug #82778, please see Bug #82778.
Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Regards,
Ashwini Patil