Bug #101055 Debian Buster mysql 5.6 repository empty
Submitted: 5 Oct 2020 17:14 Modified: 17 Feb 14:27
Reporter: John Hunt Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.6 OS:Debian
Assigned to: CPU Architecture:Any

[5 Oct 2020 17:14] John Hunt
Description:
At https://repo.mysql.com/apt/debian/dists/buster/mysql-5.6/

both the amd64 and i386 versions have empty packages lists. You can add this specific version of the repository in debian, but it will not actually find any installable version of 5.6 even though the stubs seem to exist.

How to repeat:
https://repo.mysql.com/apt/debian/dists/buster/mysql-5.6/binary-amd64/Packages

notice that it is empty
[5 Oct 2020 17:39] MySQL Verification Team
Thank you for the bug report.
[17 Feb 14:27] Erlend Dahl
[13 Jan 2021 6:18] Sreedhar Sreedhargadda

Debian 10(buster) is not supported on MySQL server 5.6. Only Debian 9 is supported.

For any latest Debian/Ubuntu versions we need to use MySQL server 8.0