Bug #10080 ODBC connector does not return datetime or timestamp fields
Submitted: 22 Apr 2005 0:20 Modified: 30 May 2013 13:03
Reporter: bill sappington Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.11.0 OS:Microsoft Windows (Windows XP Pro SP2)
Assigned to: Assigned Account CPU Architecture:Any

[22 Apr 2005 0:20] bill sappington
Description:
Program written using Delphi and BDE 5.5 access Mysql server 4.x via MYODBC.

Server running on Redhat program workds correctly via ODBC from both WIn98SE & Win2Kpro.  Information is accessed via both tTable components & tSQL components.

Install OBDC 3.51.11.0 on Windows XP Pro SP2, Install Delphi built software on WInXP box and both datetime & timestamp are not returned.  Pointed System DSN to Redhat server and same result.

Install MySQL Server 4.x on Windows XP Pro SP2, Install Delphi built software on WInXP box and both datetime & timestamp are not returned.  Pointed System DSN to local host with same result.

How to repeat:
Install latest windows binary of SQL server on a windows XP Pro SP2 box.
Install ODBC, setup a standard ( take defaults ) local host connection.
Create table with datetime and or timestamp fields.
Build a standard delphi 5 app using a TTable component, a TDatasource component and tDataGrid component.
Point the delphi app and the system DSN.
Run Program.

Suggested fix:
Just fix it.
[22 Apr 2005 2:02] Jorge del Conde
Verified w/3.51.11-2
[22 Apr 2005 3:37] bill sappington
This is the ODBC Trace.

Attachment: odbctrace.zip (application/zip, text), 22.91 KiB.

[22 Apr 2005 3:38] bill sappington
Just for fun I backreved to myodbc 2.5 ( windows ) and it exploded in a spectacular fashion. <grin>
[23 Apr 2005 0:50] bill sappington
Forgot to add the server version.

Server Version 4.0.15-standard
Protocol version 10
[25 Apr 2005 19:19] bill sappington
When are we going to see some action on this, like uhmmm assigned to a developer, something that shows someone is taking this seriously.

I am dead stopped!  I cannot continue to develop this application.  Do i need to switch to something like Oracle?

Guys this is serious, this is business.  What is being done to solve this???

I cannot back-rev this machine to win2K which is being de-supported at the end of the year.

PLEASE FIX THIS ASAP
[25 Oct 2005 15:14] Peter Harvey
Please try c/odbc v3.51.12 and report success/failure. This new version of MyODBC has some fixs related to date/time data types.
[26 Nov 2005 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[30 May 2013 13:03] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.