Bug #100686 8.0 mysqldump does not work against 5.7 server
Submitted: 29 Aug 2020 0:50 Modified: 29 Aug 2020 6:13
Reporter: Venkatesh Duggirala Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: mysqldump Command-line Client Severity:S2 (Serious)
Version:8.0.18 OS:Any
Assigned to: CPU Architecture:Any

[29 Aug 2020 0:50] Venkatesh Duggirala
Description:
Document says "https://dev.mysql.com/doc/refman/8.0/en/mysqldump.html#option_mysqldump_column-statistics" it is disabled by default. 

But source code 
mysqldump.cc gives "1" as the default. This is the problem. 

client/mysqldump.cc ====
246c246
<      &column_statistics, &column_statistics, 0, GET_BOOL, NO_ARG, 1, 0, 0, 0, 0,
---
>      &column_statistics, &column_statistics, 0, GET_BOOL, NO_ARG, 0, 0, 0, 0, 0,

How to repeat:
1) Start Mysql 5.7 
2) Use mysql 8.0's mysqldump to connect to 5.7 server => Fails
[29 Aug 2020 6:13] MySQL Verification Team
Dear Venkat,

Thank you for the report and feedback.
Imho this is duplicate of Bug #89825.

regards,
Umesh