Bug #10061 mysql hang
Submitted: 21 Apr 2005 14:29 Modified: 12 May 2005 4:42
Reporter: Elim Qiu Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S1 (Critical)
Version:5.0.3-beta-nt OS:Microsoft Windows (windows 2000 pro)
Assigned to: CPU Architecture:Any

[21 Apr 2005 14:29] Elim Qiu
Description:
after coppied database folders from previous installation (5.0.1-alpha-nt).
login from mysql client, select database by command 
mysql>use mydata;
mysql>show tables;

The last command will cause the database server hang (100% cpu, eats system memory until the system crash)

How to repeat:
The following table list is obtained by 5.0.1-alpha-nt and mysql client
with 'show tables' command.

add any of the following to a system with new installation will cause 
the same trouble. Maybe 'BASE TABLE' is the reason?

+-------------------------+------------+
| Tables_in_esite         | table_type |
+-------------------------+------------+
| address                 | BASE TABLE |
| address_association     | BASE TABLE |
| affair                  | BASE TABLE |
| category_keyword        | BASE TABLE |
| data_access             | BASE TABLE |
| e_contact_association   | BASE TABLE |
| e_contact_entry         | BASE TABLE |
| e_data                  | BASE TABLE |
| e_document              | BASE TABLE |
+-------------------------+------------+
[24 Apr 2005 21:59] Jorge del Conde
I wasn't able to reproduce this with later 5.0 (non alpha) versions.

Can you please try to reproduce this bug using non alpha versions of mysql ?

Thanks !
[25 Apr 2005 14:54] Elim Qiu
CSite database to reproduce the bug in 5.0.3 beta

Attachment: CSites.rar (application/octet-stream, text), 27.46 KiB.

[7 May 2005 7:20] Elim Qiu
I've uploaded a database, if you copy it to your data folder of 5.0.3-beta-nt
on win2k pro, can you still using 
mysql> show tables;

to list the tables?
in my case, this will cause the system hang
[7 May 2005 15:14] Elim Qiu
Looks like I got the reason: Database name cannot have uppercased chars:
db named 'ESite' will cause problem (do 'show tables' causes system hang) while 
db name 'esite' is ok.
[12 May 2005 4:42] Miguel Solorzano
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Verified with the uploaded tables:

c:\mysql\bin>mysql -uroot
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 5.0.6-beta-nt

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> use db1;
Database changed
mysql> show tables;
+----------------------------+
| Tables_in_db1              |
+----------------------------+
| address                    |
| address_association        |
| bhcourse                   |
| bhcourse_class             |
| bhschool_season            |
| e_data                     |
| e_document                 |
| e_keyword                  |
| e_relation                 |
| e_type                     |
| econtact_entry             |
| econtact_entry_association |
| emailing_list              |
| enterprise_program         |
| enterprise_season          |
| enterprise_unit            |
| eo_pk_table                |
| geo_region                 |
| person                     |
| person_group               |
| person_group_person        |
| person_participation       |
| person_relation            |
| system_event_log           |
+----------------------------+
24 rows in set (0.01 sec)

mysql>