Bug #10059 SHOW TABLE STATUS FROM `information_schema`; reports uppercase table names
Submitted: 21 Apr 2005 13:43 Modified: 1 Jun 2005 4:00
Reporter: MySQL-Front Team Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.0.4-beta OS:Microsoft Windows (Windows XP)
Assigned to: Sergey Glukhov

[21 Apr 2005 13:43] MySQL-Front Team
Description:
SHOW TABLE STATUS FROM `information_schema`; 

reports all tablenames in uppercase - even while the 

SHOW CREATE TABLE `information_schema`.`TABLES`;

shows:

CREATE TEMPORARY TABLE `tables` (
  ...
) ENGINE=MEMORY DEFAULT CHARSET=utf8 MAX_ROWS=4607;

So one of both is wrong...

How to repeat:
SHOW CREATE TABLE `information_schema`.`TABLES`;

shows:

CREATE TEMPORARY TABLE `tables` (
  ...
) ENGINE=MEMORY DEFAULT CHARSET=utf8 MAX_ROWS=4607;

SHOW TABLE STATUS FROM `information_schema`; 

shows all tablenames in uppercase.
[21 Apr 2005 14:32] Jorge del Conde
Hi,

I was unable to reproduce this bug using 5.0.5 from bk:

mysql> SHOW CREATE TABLE `information_schema`.`TABLES`;
<cut>
| TABLES | CREATE TEMPORARY TABLE `TABLES` (
..
) ENGINE=MEMORY DEFAULT CHARSET=utf8 |
[28 Apr 2005 7:45] Hartmut Holzgraefe
can't reproduce this on Linux, maybe it's related to Windows Filesystems being case insensitive?
[3 May 2005 1:25] Jorge del Conde
I was able to reproduce this under WinXP:

mysql>  show create table information_schema.TABLES;
<cut>
| tables | CREATE TEMPORARY TABLE `tables` (
[24 May 2005 11:58] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25209
[31 May 2005 8:18] Sergey Glukhov
Fixed in 5.0.7
[31 May 2005 17:13] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25418
[1 Jun 2005 4:00] Paul Dubois
Noted in 5.0.7 changelog.