Bug #10042 Application Error
Submitted: 20 Apr 2005 18:11 Modified: 20 Apr 2005 19:51
Reporter: Shane Osaki Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S1 (Critical)
Version:1.0.5 Beta OS:Microsoft Windows (XP Pro SP2)
Assigned to: CPU Architecture:Any

[20 Apr 2005 18:11] Shane Osaki
Description:
When trying to run the program, it does not open at all, and gives this error message:

Exception Exception in module MySQLMigrationTool.exe at 0019D384. The GRT environment could not be initialized. The call of Migration:initMigration() failed. The function did not return an object. Error Nr. 10003.

Once the error message is dismissed, a command prompt style window comes up with another message:

** (process:3956): CRITICAL **: file .\source\myx_grt_value.c: line 2054: assertion 'list->type == MYX_LIST_VALUE' failes

Once the window is closed, a final error message pops-up:

Runtime error 216 at 00403B8A

How to repeat:
This problem can be replicated by attempting to open the program again.
[20 Apr 2005 19:51] Jorge del Conde
I was unable to reproduce this bug using winxp & sp2.
[21 Apr 2005 16:39] Shane Osaki
I have just uninstalled and reinstalled the Migration Toolkit on the same machine in question, but upon trying to run the program, the same error message shows up. I have also tried a clean install on another XP Pro SP2 machine that I have, and it results in the same error message.

Perhaps I have a bad MSI copy? I noticed that most of the links to download this program from the mirrors were broken. Can anybody give me input?
[12 May 2005 17:02] Mauricio Perez
Hello,

I'd installed mysql-migration-toolkit-1.0.5-beta on my winXP SP1, with JRE 1.4.X but when the application try to start the following error appears:

"The GRT Environment cannot be initialized"

And after appears the tipical windows notification error form without start the program.

Please, Help.

Mauricio Perez Ll.
Santiago,Chile
[14 May 2005 19:17] Charles Rethman
I am running Win XP SP2. Exact Version and Build: 5.1 (Build 2600.xpsp_sp2_gdr.050301-1519: Service Pack 2.

I have the same problem that the Migration Toolkit crashes with the same set of error messages as reported by the other users. I upgraded from the Migration Toolkit 1.0.1 alpha (which gave me trouble when I was actually importing) to 1.0.5 beta.

I am using the new Server 5.0.4 beta (need those SPs and SFs!).

I have tried reinstalling, rebooting, etc. to no avail.

I have screen shots with the error messages, if wanted. Contact me on my email.

Cheers,

Charles Rethman.
[30 May 2005 17:23] Gaylord Levy
I already have got this error, too.

I'm using:

Windows 2000 Pro w/sp3
MySQL 4.1.12-nt
MySQLMigrationTool 1.0.7.0
Java 1.5.0_02-b09

I tried to export MSSQL database tables to plain-text files in first place, then those plain-text files to MySQL, but there is a problem with NULL values.

I would like to try this Tool to see if the problem with NULL values is gone.

Thanks in advance,
[15 Jul 2005 13:24] Steve Simmons
I get the same error.

Windows XP Professional SP1
MySQL 4.1.12a
Migration Toolkit 1.0.10