Bug #1004 Mysql crashes and won't install on Red Hat Enterprise Linux 3 Beta 1 (Taroon)
Submitted: 5 Aug 2003 10:19 Modified: 10 Nov 2003 6:02
Reporter: [ name withheld ] Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S1 (Critical)
Version:4.0.14-0 OS:Linux (Red Hat Enterprise Linux 3)
Assigned to: Lenz Grimmer CPU Architecture:Any

[5 Aug 2003 10:19] [ name withheld ]
Description:
When installing the rpms (or the tar file) onto Red Hat Advance Server Beta 1 (Taroon), we get the follwing error:

Installing all prepared tables
/usr/bin/mysql_install_db: line 1:  7690 Segmentation fault      /usr/sbin/mysqld --bootstrap --skip-grant-tables --basedir=/ --datadir=/var/lib/mysql --skip-innodb --skip-bdb
Installation of grant tables failed

The log file simply shows a start and a stop of the server.

How to repeat:
1) Load RH AS Beta 1:

Installable binary ISO images, RPM packages, and source RPMs are
available at:

    ftp://ftp.redhat.com/pub/redhat/linux/beta/taroon

Or the following mirrors:

 North America:
  United States:
    ftp://ftp.cse.buffalo.edu/pub/RedHat/redhat/linux/beta/taroon/
    ftp://kickstart.linux.ncsu.edu/pub/redhat/linux/beta
    ftp://ftp.oregonstate.edu/pub/ftp.redhat.com/beta/taroon
  Canada:
    ftp://ftp.nrc.ca/pub/systems/linux/redhat/ftp.redhat.com/linux/beta/taroon

 Europe:
  Czech Republic:
    ftp://sunsite.mff.cuni.cz/MIRRORS/ftp.redhat.com/redhat/linux/beta/taroon
    ftp://ultra.linux.cz/MIRRORS/ftp.redhat.com/redhat/linux/beta/taroon
  Germany:
    ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/redhat/linux/beta/taroon
    http://sunsite.informatik.rwth-aachen.de/ftp/pub/Linux/redhat/linux/beta/taroon
    ftp://ftp.tu-chemnitz.de/pub/linux/redhat-ftp/redhat/linux/beta/taroon/
    http://wftp.tu-chemnitz.de/pub/linux/redhat-ftp/redhat/linux/beta/taroon/
  Netherlands:
    ftp://ftp.nluug.nl/pub/os/Linux/distr/RedHat/ftp/redhat/linux/beta/taroon/
    ftp://ftp.surfnet.nl/pub/os/Linux/distr/RedHat/ftp/redhat/linux/beta/taroon/
  Romania:
    ftp://ftp.iasi.roedu.net/pub/mirrors/ftp.redhat.com/pub/redhat/linux/beta/taroon/
  Russia:
    ftp://ftp.chg.ru/pub/Linux/redhat/linux/beta/taroon/
    http://ftp.chg.ru/pub/Linux/redhat/linux/beta/taroon/
  Switzerland:
    ftp://sunsite.cnlab-switch.ch/mirror/redhat/linux/beta/taroon/

 Asia/Pacific:
  Australia:
    http://planetmirror.com/pub/redhat/linux/beta/taroon/
    ftp://ftp.planetmirror.com/pub/redhat/linux/beta/taroon/

2) rpm -Uvh MySQL-server-4.0.14-0.i386.rpm MySQL-client-4.0.14-0.i386.rpm
[5 Aug 2003 10:20] [ name withheld ]
.
[5 Aug 2003 11:18] [ name withheld ]
The actual name of the OS is Red Hat Enterprise Linux 3 Beta 1 (Taroon)
[13 Aug 2003 11:55] [ name withheld ]
FYI this is also reported to RedHat as 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=101695

But they've marked this as CLOSED, DEFERRED.  Looks like they're ignoring this issue ... I suspect this is an important platform for MySQL.  Also, someone sent me an email saying they've had similiar problems with Red Hat (severn) 9.0.93.

I'm adding RedHat's last comment.  If you scroll to the bottom, you'll see that they point the finger at the perl libraries or other client libraries.  Perhaps the MySQL rpm's need to have their dependencies tightened?

------- Additional Comment #3 From Patrick Macdonald on 2003-08-12 16:14 -------

Ok... downloaded the MySQL packages from mysql.com.  Made sure I had the 
correct perl-DBD, perl-DBI and perl-CGI packages installed.  Since the 
perl packages are linked against mysql-3.23 (which has mysqlclient.so.10), I
created a mysqlclient10 package to install this file.  The mysqlclient in 
the 4.0.14 package is mysqlclient.so.12.  

Here's the output of my install...

--- begin install 

[root@toledo patrickm]# rpm -Uvh MySQL-server-4.0.14-0.i386.rpm MySQL-client-4.0
.14-0.i386.rpm
warning: MySQL-server-4.0.14-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f
5
Preparing...                ########################################### [100%]
   1:MySQL-client           ########################################### [ 50%]
   2:MySQL-server           ########################################### [100%]
Installing all prepared tables
030812 15:47:35  /usr/sbin/mysqld: Shutdown Complete

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
This is done with:
/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h toledo password 'new-password'
See the manual for more instructions.

NOTE:  If you are upgrading from a MySQL <= 3.22.10 you should run
the /usr/bin/mysql_fix_privilege_tables. Otherwise you will not be
able to use the new GRANT command!

Please report any problems with the /usr/bin/mysqlbug script!

The latest information about MySQL is available on the web at
http://www.mysql.com
Support MySQL by buying support/licenses at https://order.mysql.com

Starting mysqld daemon with databases from /var/lib/mysql

---- end of install

So the problem could be that your system does not have the required
perl packages installed or that the MySQL access methods in the Taroon
beta are linked against mysqlclient.10 not 12 (which is provided in the
MySQL.com packages) which is causing the MySQL.com supplied packages to
fail on install.
[22 Sep 2003 0:03] Miguel Solorzano
LenZ: Please read the last comments about Perl's dependencies.
It isn't Jani's issue !
[22 Sep 2003 8:43] Lenz Grimmer
Actually, there are two issues here. One is the conflicting libraries issue,
which can be resolved by installing the MySQL-shared-compat RPM, as documented
in the manual.

The second issue is the segfault inside of /usr/bin/mysql_install_db which is not related to the client libraries at all. We have received several reports 
from users having trouble with our (statically linked) binaries on newer Red Hat releases (e.g. RedHat AS 3.0 beta). I just find it interesting that Red Hat
was not able to reproduce this crash. We will investigate this, as soon as we have an installation of RH AS beta installed somewhere.
[10 Nov 2003 6:02] Lenz Grimmer
As an update to this, the crash does not happen anymore with the final version
of Red Hat AS 3.0 - therefore I close this bug now.