Bug #10019 Description of "No suitable driver" in documentation omits a possible cause
Submitted: 19 Apr 2005 22:47 Modified: 2 Aug 2006 8:54
Reporter: Robert Dodier Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / J Documentation Severity:S3 (Non-critical)
Version:connector/j 3.1.8 OS:Linux (Linux)
Assigned to: MC Brown CPU Architecture:Any
Triage: D4 (Minor)

[19 Apr 2005 22:47] Robert Dodier
Description:
The Connector/J documentation (http://dev.mysql.com/doc/connector/j/en/cj-faq.html) in section 1.5.1.2 says that "No suitable driver" can be caused by classes not in the classpath, or a mistaken URL. I've found a third cause. 

java.sql.DriverManager loads available drivers based on the jdbc.drivers system property. If there are no drivers specified, then the DriverManager does not find a  driver, and it throws the "No suitable driver" exception. (See the comment header for the DriverManager class. I am working with JDK 1.5.)

How to repeat:
(Not applicable; this is a documentation bug.)

Suggested fix:
I think jdbc.drivers should be mentioned in section 1.5.1.2, or maybe elsewhere as well.

Hope this helps!
[2 Aug 2006 8:54] MC Brown
A note on this issue has been added to the Connector/J documentation.