Bug #100080 MySQL 8.0.20 LDAP simple authentication broken
Submitted: 2 Jul 9:16 Modified: 2 Jul 11:24
Reporter: Oli Sennhauser Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Pluggable Authentication Severity:S2 (Serious)
Version:8.0.20 OS:Linux (Ubunut 18.04)
Assigned to: CPU Architecture:x86
Tags: authenication, LDAP, simple

[2 Jul 9:16] Oli Sennhauser
Description:
LDAP simple authentication in MySQL 8.0.20 does not work any more. We do not even get a message in the MySQL error Log (with authentication_ldap_simple_log_status = 6).
Downgrading to 8.0.19 it worked again.

How to repeat:
Just follow MySQL documentation:

mysql --user=betsy --password --host=192.168.56.1 --enable-cleartext-plugin --plugin-dir=/home/mysql/product/mysql-8.0.20/lib/plugin
Enter password: 
ERROR 1045 (28000): Access denied for user 'betsy'@'localhost' (using password: NO)
[2 Jul 11:22] MySQL Verification Team
Hi Oli,

Workaround:

[mysqld]
authentication_ldap_simple_auth_method_name=simple

Note value is in lowercase.
[2 Jul 11:24] MySQL Verification Team
Duplicate of my internal Bug 31320532