Bug #100047 Segmentation fault on import mysql.connector
Submitted: 30 Jun 2020 9:56 Modified: 11 May 17:32
Reporter: Aditya Prakash Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / Python Severity:S2 (Serious)
Version:8.0.20 OS:Any
Assigned to: CPU Architecture:Any

[30 Jun 2020 9:56] Aditya Prakash
Description:
Running 'import mysql.connector' gives Segmentation fault when using mysql-connector-python==8.0.20

How to repeat:
Run following command:
`sudo docker run -it python:3.7-slim bash -c "pip install mysql-connector-python==8.0.20; python -c 'import mysql.connector'"`

Expected output:
exit successfully with status zero.

Actual output:
bash: line 1:    14 Segmentation fault      (core dumped) python -c 'import mysql.connector'

Suggested fix:
Use 8.0.19.
[30 Jun 2020 10:23] MySQL Verification Team
Thank you for the bug report.
[1 Jul 2020 13:53] Daniel Katz
This might be a duplicate of one I recently reported:
https://bugs.mysql.com/bug.php?id=99923

Workaround is `apt update && apt install -y libkrb5-dev`.
[11 May 17:32] Philip Olson
Yes, this is considered a duplicate, and we're sorry for taking so long to respond. This bug is considered fixed as of 8.0.22 when the build system was rewritten. Thank you for the bug report!